Sunday, March 18, 2007

Poseball and A/O animation FAQ

OK Ill add to this when think of more things.

I sell 3 types of poseball, the first is the regular non-synched older type, this also includes the single anims and couple poses that also come in full perms versions.
The second is the synch type, these ones require AVs on both balls before they will animate, they contain more complex couples animations generally of about 30 seconds length looped.
The third type are the sequence sets, these work in the same way as the synch ones but are designed to play 2 or more 30 second animations as a continuous animation(the max length SL will allow an animation to be is 30 seconds so the script controls the sequence and length of time each is played, it also controls the looping).


I dragged the folder to the ground to rez it, it didnt appear and now the set is not in my inventory.

When rezzing a ballset DO NOT drag the entire folder to the ground, if you do this SL thinks you wish to place that folders contents INTO the contents of whatever prim you drag it onto, the folder and notecards will remain in your inventory because they are copiable, the ballset will be transfered into the contents of whatever prim your dragged the folder onto.

If this has happened, right click and edit the prim you dragged the folder onto, be it a floor prim, bed etc, in the build box which comes up press "more", then press the "contents" tab, in here you should see the ballset and the 2 notecards, left click the ballset and drag it back into the folder in your inventory.

To rez the ballset you must open the folder and locate the small box type object which is in the folder with the notecards(this is the actual ballset), drag this item ONLY from your inventory onto whichever surface you wish to rez the set on.

I rezzed the ballset and when I sit on them I'm inside the ground.

All poseball sets must be positioned after rezzing, this basically involves sitting on one of the balls, right click on the other and "edit", then use the movement arrows to bring the ball upward, left, right etc, your AV will move as you do this so you can tell when you are in the place you want, once done close the build box, the set will remain where it is until you take and rez it again.

How do I adjust the set so that it fits my and my partners AV sizes?

To do this first the set must be unlinked, hop off both balls, right click and "edit" on the set, then in the "tools" menu in the top bar on your screen, the pull down menu has an option "unlink",
once unlinked hop onto the set, if the set is regular(not sync or sequence) say /1 show so that the balls appear while you are on them, its then a case of moving one of them until your AV is correctly positioned with your partner, once you have done this hop both people off the set again.
To relink right click on the pink ball and "edit", hold down CTRL and left click on the blue ball(you may need to zoom to make this easier), after this you should have both balls outlined so both are selected, then go to the "tools" menu in the top bar again and select "link" from the dropdown menu.
If the set you are doing this with is a synch or sequence set, the text will be red when they are unlinked, when unlinked these sets only play a static animation frame to ease positioning, once relinked the text will turn white and they will animate again, I find actually the best way to adjust these type is to watch the anim and decide which way the female ball needs to go to make it better, I then unlink and move the pink a small amount in the direction I had decided, I do this without AVs on the set, I then relink and try the anim again to see if that movement improved it, the trick is to only move slightly each time.

I have done the above but just cannot get the anim to look right on our AVs.

Unfortunately its not always possible to get a correct fit given the huge variety of AV sizes and size differences possible in SL, with the shorter anims its not such a problem, but with the very long ones where both partners move a lot more, if the AVs being used are of extreme difference in size its likely not all parts of the anim will mesh properly, a couple animation can only ever be 100% correct if the AVs being used match the test ones used by the animator, which of course means animations made by different animators are all based on different AV sizes, its not possible to anticipate all possible AV sizes and size differences, this would involve making infinite versions of the same animation adjusting every point to accommodate every possible body measurement.
Below are the measurements of the 2 AVs that we currently use when making anims.

BodyHeight 53
Body thickness 31
Body fat 8
Head size 65
Torso muscles 42
Neck thickness 47
Neck length 27
Shoulders 60
Pectorals 24
Arm length 30
Hand size 50
Torso length 43
Love handles 32
Belly size 7
Leg muscles 67
Leg length 50
Hip width 57
Hip length 56
Foot size 39

BodyHeight 40
Body thickness 26
Body fat 17
Head size 60
Torso muscles 49
Neck thickness 48
Neck length 51
Shoulders 49
Breast Size 60
Arm length 70
Hand size 43
Torso length 52
Love handles 40
Belly size 16
Leg muscles 57
Leg length 66
Hip width 60
Hip length 49
Foot size 30

Of course I don't expect people to change their AV sizes to suit a pair of poseballs, if you simply cannot get a set to suit your AVs as you would like, contact me and if the set was bought from me you can return it for a refund.

My sych/sequence set of pose balls is not working properly

Ok assuming the 2 are linked(the text should be white not red), and the scripts and/or animations have not been removed from the balls contents....
The one thing that "breaks" these types of sets is a sim crash while they are being used, even if you personally didn't witness the sim crash it could have happened while you were offline and maybe someone else was using the set, a sim crash break can take a few different forms:

The set may be spamming a script error like "script trying to trigger animation but PERMISSION_TRIGGER_ANIMATION not set" etc etc.
The set may go to the correct start position for one partner but the other will just "sit" on the ball in the regular Linden sit, or both may just sit.
One or both balls may have disappeared, they are not really gone, its just the sim crash happened before the script had the chance to reshow the balls after the AVs were logged out

In all these cases the scripts have become locked, stand near the set and say

/1 reset

As of December 2006, we put new scripts into all synch and sequence sets, this command will always fix a sim crashed set and return it to working order, if you have an older set send it back to me and Ill send the newer type.

Oh and if you did remove scripts or anims from the set just say so ok, I do look at the returns and contents removal can only be done by the owner,a person with their mod rights, or a group member if its group owned, contents don't disappear from a ballset, they have to be intentionally removed or deleted, its not a hanging offense, I don't expect people to know all the do's and dont's of SL, Ill still replace the set if its the first time and was an accident.

My poseballs vanished from my land.

OK this can be a number of things, the first is they may still be there but hidden, someone could have come to the land and said /1 hide, in which case stand where they were and say /1 show.
Another possibility is a sim crash occurred while they were being used, as mentioned in the above answer, stand where they were and say /1 reset.
Another one particularly common with rented land is you rezzed them without having the renters group tag activated, in which case the set was auto-returned to you and should be in your "lost and found" folder, however Linden recently introduced a "feature" where if a number of objects were returned at once they are bunched together in lost and found with sometimes the name "object", to find out if the ballset was bunched together with other things in this way rez the "object", you may find its several different things including the ballset(s) that disappeared.
Another more recent addition is "no object entry" on a parcel, I have only seen this once when I rezzed an item without my group tag on in land with this option on, the item I rezzed was zapped to the very corner of the sim and high in the air, Im assuming if you do this on a mainland parcel the object you rezzed will be relegated to the parcel closest that does allow object rez, in which case it could be returned shortly by auto return or the next time that parcel owner checks his/her prims, I should stress I have not fully looked into how this works.

Of course SL being SL it could have had one of its moments and they really did disappear, if you tried the above things and no joy the best thing is to open a support ticket with Linden Labs on their support page, state exactly what happened and steps you took to try to find the items, on many occasions Linden can help, if however they reply and say they cannot, contact myself, Yoshi or Yawneeb(whoever was the maker of the one(s) you lost), if the items were bought within the last 12 months we should be able to find the purchase in history, you must be using the AV that bought the items as we have no way to say who is an "alt" of who.

Can I change the listen channel to /2 hide, /3 hide etc?

OK inside each ballset(except Tango) is a script called "Parameters Master", this is a modifiable script which is commented and has the line:

integer CHANNEL = 1;

Just change the 1 to whatever number you wish to use for the channel it hides and shows on, for instance to make the set respond to /99 hide or /99 show

integer CHANNEL =99;

Can I change the name on the float text?

There is a line in the "Parameters" script which allows you to do this, if its a couple set remember to use "edit linked parts" to get to the contents of the second ball to change that ones text also, the line to change is:

string NAME = "Play piano";

if you wished the text to say "Play Keyboard", change that line to:

string NAME = "Play Keyboard";

Then "save" at the bottom of the script and close it, the text will then change.

If it is a couple set please note there is also a parameters script in the pink ball which controls the float text above that one, to get to this parameters script either select "edit linked parts" in the build box and left click the pink ball, or unlink the pair and edit the pink.

If you wish to remove the text do as above but change the anim name to " "(a blank space).

You say all your poseballs are modify, but this set in my inventory says (no modify)

OK all ballsets bought from me ARE modifiable, they can be unlinked if a couple set, they can be retextured/coloured etc, the set says (no modify) when in your inventory because the main script in the balls is no mod, the way inventory works is it says (no modify) if any internal part is no mod, if you rez the set you will find the balls are modifiable.

I bought a set from you and dont see it in my inventory.

All couple/multiple sets I make sell as a folder, they make a folder with the name of the set containing notecard(S) and the ballset, single anim balls go into your "objects" folder, if you dont see the folder press the "recent items" tab in your inventory, this shows all objects you received since you logged in.

In some cases SL is being slow, and it can take a while before the item is delivered to your inventory, if you dont have the item try logging out and back in again, clearing the SL cache can sometimes update your inventory, that also requires logging back in.

Again if no joy after trying these things, IM me or Yoshi.

I bought an AO animation but when I use it I walk on the spot, I wanted it to replace my default SL walk

The walks and stances I sell are FOR animation overriders, they are not animation overriders in themselves, that said if you need an animation overrider to put the walk/stance into, just send me an IM and Ill send you one ok, it has instructions but if you get stuck I have set them up before and can help ok

I bought your crawl animation but its puts me in the ground/floating above the ground

OK this is another AV size dependant thing, depending on your height(hip height to be specific), the anim may not go to the ground or it may go too far into the ground, if your AV is shorter than my test one it will be in the ground, if taller it will be floating above the ground, this is simply because the anim moves the hips(which is the governing factor in anims) a certain distance down so that the hands and knees are on the ground, of course if the AV is taller then the distance it moves down will not be enough to bring that AV to ground level, if the AV is shorter then it will bring you down too far.
But all is not lost, send me an IM to say if its putting you too high or too low, I do have a selection of the crawl anims where I altered the hip up and down, I will be able to supply one that will suit your AV height.

What are the timer settings for longer sequence anims when used in a Multi Animation Tool?

The anims used in these sets are of a 30 second duration(the maximum length SL will allow an animation to be), however because SL uses the first frame for rotation settings and then removes that frame, the actual length is less, the times I use in the sets are:

28.5 to 29.8 seconds

Now this may seem odd because you would expect a 30 second anim to always be the same timer setting, but in testing I found some were "jumpy" with the normal first setting I use of 29.5, I cannot fully explain it but I think its possibly related to the fact I dont always use the same frame rate of animations(there is good reason for that but I wont go into it now), also that depending on sim load etc, script timers I have found can run slow sometimes.

You can tell if a timer is too short or too long however, if you find that the anims are "snapping" into each other, the movement is smooth and suddenly a limb snaps to its next position, this means the anim had not ended by the time the script called in the next one, thus it might be worth increasing the time from maybe 29.5 to 29.7, if you timer is too long you may find at the join between animations the couple appear to jump up for a split second, this means the anim ended and SL was attempting to play a default anim just as the next anim started, if this is the case make the time slightly less by 0.2 and watch the anim again.

As with many things in SL, unfortunately there is no perfect setting, script timers are not too accurate, and a lot depends on the speed of the sim, the speed of connection etc, also on the fact that anims are downloaded to the client before they are played and cached(this is the reason if you use a set you havent used before you may sit there for ages before the anim starts), Ill put more on this in the general FAQ Im writing at the moment.